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Installing the SDK
This page describes how to install the Android SDK and set up your development environment. If you haven't downloaded the SDK yet, you can use the link below to get started. Then read the rest of this document to learn how to install, configure, and use the SDK to create Android applications.
Download the SDK
Upgrading?
If you have already downloaded an earlier version of the SDK and developed applications on it, please read the Upgrading the SDK document instead. The Upgrading document explains how to migrate your existing development environment and applications to the new SDK release. The document also provides information that you will find useful during the upgrade, such as lists of framework and API changes. 
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[bookmark: developmentrequirements]System and Software Requirements
To develop Android applications using the code and tools in the Android SDK, you need a suitable development computer and development environment, as described below.
Supported Operating Systems
· Windows XP or Vista 
· Mac OS X 10.4.8 or later (x86 only) 
· Linux (tested on Linux Ubuntu Dapper Drake) 
Supported Development Environments
· Eclipse IDE 
· Eclipse 3.2, 3.3 (Europa) 
· Eclipse JDT plugin (included in most Eclipse IDE packages) 
· WST (optional, but needed for the Android Editors feature; included in most Eclipse IDE packages) 
· JDK 5 or JDK 6 (JRE alone is not sufficient) 
· Not compatible with Gnu Compiler for Java (gcj) 
· Android Development Tools plugin (optional) 
· Other development environments or IDEs 
· JDK 5 or JDK 6 (JRE alone is not sufficient) 
· Not compatible with Gnu Compiler for Java (gcj) 
· Apache Ant 1.6.5 or later for Linux and Mac, 1.7 or later for Windows 
Note: If JDK is already installed on your development computer, please take a moment to make sure that it meets the version requirements listed above. In particular, note that some Linux distributions may include JDK 1.4 or Gnu Compiler for Java, both of which are not supported for Android development. 
[bookmark: installingsdk][bookmark: setup]Installing the SDK
After downloading the SDK, unpack the .zip archive to a suitable location on your machine. By default, the SDK files are unpacked into a directory named android_sdk_<platform>_<release>_<build>. The directory contains the subdirectories tools/, samples/, and others. 
Make a note of the name and location of the unpacked SDK directory on your system — you will need to refer to the SDK directory later, when setting up the Android plugin or using SDK tools. 
Optionally, you can add the path to the SDK tools directory to your path. As mentioned above, the tools/ directory is located in the SDK directory. 
· On Linux, edit your ~/.bash_profile or ~/.bashrc file. Look for a line that sets the PATH environment variable and add the full path to the tools/ directory to it. If you don't see a line setting the path, you can add one: 
export PATH=${PATH}:<your_sdk_dir>/tools
· On a Mac, look in your home directory for .bash_profile and proceed as for Linux. You can create the .bash_profile, if you haven't already set one up on your machine. 
· On Windows, right click on My Computer, and select Properties. Under the Advanced tab, hit the Environment Variables button, and in the dialog that comes up, double-click on Path under System Variables. Add the full path to the tools/ directory to the path. 
Adding tools to your path lets you run Android Debug Bridge (adb) and the other command line tools without needing to supply the full path to the tools directory. Note that, if you update your SDK, you should remember to update your PATH settings to point to the new location, if different.
[bookmark: installingplugin]Installing the Eclipse Plugin (ADT)
Tips for downloading ADT
If you are having trouble downloading the ADT plugin after following the steps listed at left, here are some suggestions: 
· In Step 4, try changing the remote update site URL to use http, rather than https. 
· If you are behind a firewall (such as a corporate firewall), make sure that you have properly configured your proxy settings in Eclipse. In Eclipse 3.3, you can configure proxy information from the main Eclipse menu in Window > Preferences > General > Network Connections. In Eclipse 3.2, use Window > Preferences > Install/Update. 
If you are still unable to use Eclipse to download the ADT plugin, follow these steps to download and install the plugin from your computer: 
1. Download the ADT zip file 
2. Unpack the zip file in its own folder 
3. Follow steps 1 and 2 in the default install instructions (on the left) 
4. Press New Local Site... 
5. In the resulting dialog box, select the folder where you unpacked the zip file 
6. Follow steps 5 through 11 in the default install instructions (on the left) to complete the installation 
Note that to update your plugin, you will have to follow these steps again instead of the default update instructions.
If you will be using the Eclipse IDE as your environment for developing Android applications, you can install a custom plugin called Android Development Tools (ADT), which adds integrated support for Android projects and tools. The ADT plugin includes a variety of powerful extensions that make creating, running, and debugging Android applications faster and easier.
If you will not be using the Eclipse IDE, you do not need to download or install the ADT plugin.
To download and install the ADT plugin, follow the steps below. 
1. Start Eclipse, then select Help > Software Updates > Find and Install.... 
2. In the dialog that appears, select Search for new features to install and press Next. 
3. Press New Remote Site. 
4. In the resulting dialog box, enter a name for the remote site (e.g. Android Plugin) and enter this as its URL: 
https://dl-ssl.google.com/android/eclipse/
Press OK. 
5. You should now see the new site added to the search list (and checked). Press Finish. 
6. In the subsequent Search Results dialog box, select the checkbox for Android Plugin > Developer Tools. This will check both features: "Android Developer Tools", and "Android Editors". The Android Editors feature is optional, but recommended. If you choose to install it, you need the WST plugin mentioned earlier in this page. 
Now press Next. 
7. Read the license agreement and then select Accept terms of the license agreement, if appropriate. Press Next. 
8. Press Finish. 
9. The ADT plugin is not signed; you can accept the installation anyway by pressing Install All. 
10. Restart Eclipse. 
11. After restart, update your Eclipse preferences to point to the SDK directory: 
a. Select Window > Preferences... to open the Preferences panel. (Mac OS X: Eclipse > Preferences) 
b. Select Android from the left panel. 
c. For the SDK Location in the main panel, press Browse... and locate the SDK directory. 
d. Press Apply, then OK. 
Note that the "Android Editors" feature of ADT requires several optional Eclipse components (for example, WST). If you encounter an error when installing ADT, your Eclipse installion might not include those components. For information about how to quickly add the necessary components to your Eclipse installation, see the troubleshooting topic ADT Installation Error: "requires plug-in org.eclipse.wst.sse.ui".
[bookmark: Updating_the_ADT_plugin]Updating the ADT Plugin 
In some cases, a new ADT plugin may become available for your existing version of the SDK. You can use the steps below to update the ADT plugin from inside Eclipse. 
1. Select Help > Software Updates > Find and Install.... 
2. Select Search for updates of the currently installed features and press Finish. 
3. If any update for ADT is available, select and install. 
Alternatively, 
1. Select Help > Software Updates > Manage Configuration. 
2. Navigate down the tree and select Android Development Tools <version> 
3. Select Scan for Updates under Available Tasks. 
[bookmark: developingwitheclipse]Developing Android Applications on Eclipse
To begin developing Android applications in the Eclipse IDE, you first create an Android project and then set up a launch configuration. After that, you can write, run, and debug your application. 
[bookmark: creatingaproject]The sections below provide instructions assuming that you have installed the ADT plugin in your Eclipse environment. If you haven't installed the ADT plugin, you should do that before using the instructions below. See the Installing the Eclipse Plugin (ADT) for more information. 
Creating an Android Project
The ADT plugin provides a New Project Wizard that you can use to quickly create an Eclipse project for new or existing code. To create the project, follow these steps:
1. [bookmark: existingcode]Select File > New > Project 
2. Select Android > Android Project, and press Next 
3. Select the contents for the project: 
· Select Create new project in workspace to start a project for new code. 
Enter the project name, the base package name, the name of a single Activity class to create as a stub .java file, and a name to use for your application.
· Select Create project from existing source to start a project from existing code. Use this option if you want to build and run any of the sample applications included with the SDK. The sample applications are located in the samples/ directory in the SDK. 
Browse to the directory containing the existing source code and click OK. If the directory contains a valid Android manifest file, the ADT plugin fills in the package, activity, and application names for you.
4. Press Finish.
The ADT plugin creates the these folders and files for you as appropriate for the type of project:
· src/   A folder that includes your stub .java Activity file. 
· res/   A folder for your resources. 
· AndroidManifest.xml   The manifest for your project. 
[bookmark: launchconfig]Creating a Launch Configuration 
Before you can run and debug your application in Eclipse, you must create a launch configuration for it. A launch configuration specifies the project to launch, the Activity to start, the emulator options to use, and so on. 
To create a launch configuration for the application, follow these steps:
1. Select Run > Open Run Dialog... or Run > Open Debug Dialog... as appropriate. 
2. In the project type list on the left, right-click Android Application and select New. 
3. Enter a name for your configuration. 
4. On the Android tab, browse for the project and Activity to start. 
5. On the Target tab, set the desired screen and network properties, as well as any other emulator startup options. 
6. You can set additional options on the Common tab as desired. 
7. Press Apply to save the launch configuration, or press Run or Debug (as appropriate). 
[bookmark: installingrunningdebugging]Running and Debugging an Application
Once you've set up the project and launch configuration for your application, you can run or debug it as described below.
From the Eclipse main menu, select Run > Run or Run > Debug as appropriate, to run or debug the active launch configuration. 
Note that the active launch configuration is the one most recently selected in the Run configuration manager. It does not necessarily correspond to the application that is selected in the Eclipse Navigation pane (if any).
To set or change the active launch configuration, use the Run configuration manager, which you can access through Run > Open Run Dialog... or Run > Open Debug Dialog....
Running or debugging the application triggers these actions:
· Starts the emulator, if it is not already running. 
· Compiles the project, if there have been changes since the last build, and installs the application on the emulator. 
· Run starts the application. 
· Debug starts the application in "Wait for debugger" mode, then opens the Debug perspective and attaches the Eclipse Java debugger to the application. 
[bookmark: otherides]Developing Android Applications with Other IDEs and Tools
The recommended way to develop an Android application is to use Eclipse with the Android plugin. This plugin provides editing, building, and debugging functionality integrated right into the IDE. However, the SDK includes tools to enable you to develop with other IDEs, including intelliJ (or if you'd rather use Eclipse without the plugin). 
Creating an Android Project 
The Android SDK includes activityCreator, a program that generates a number of stub files for your project, as well as a build file. You can use the program to create an Android project for new code or from existing code, such as the sample applications included in the SDK. For Linux and Mac, the SDK provides activityCreator.py, a Python script, and for Windows, activityCreator.bat, a batch script. Regardless of platform, you can use activityCreator in the same way. 
To run activityCreator and create an Android project, follow these steps:
1. In the command line, change to the tools/ directory of the SDK and create a new directory for your project files. If you are creating a project from existing code, change to the root folder of your application instead. 
2. Run activityCreator. In the command, you must specify a fully-qualified class name as an argument. If you are creating a project for new code, the class represents the name of a stub class that the script will create. If you are creating a project from existing code, you must specify the name of one Activity class in the package. Command options for the script include: 
· --out <folder> which sets the output directory. By default, the output directory is the current directory. If you created a new directory for your project files, use this option to point to it. 
· --ide intellij, which generates IntelliJ IDEA project files in the newly created project 
Here's an example:
~/android_linux_sdk/tools $ ./activityCreator.py --out myproject your.package.name.ActivityName
package: your.package.name
out_dir: myproject
activity_name: ActivityName
~/android_linux_sdk/tools $ 
The activityCreator script generates the following files and directories (but will not overwrite existing ones):
· AndroidManifest.xml The application manifest file, synced to the specified Activity class for the project. 
· build.xml An Ant file that you can use to build/package the application. 
· src/your/package/name/ActivityName.java The Activity class you specified on input. 
· your_activity.iml, your_activity.ipr, your_activity.iws    [only with the -ide intelliJ flag] intelliJ project files. 
· res/   A directory to hold resources. 
· src/    The source directory. 
· bin/    The output directory for the build script. 
You can now move your folder wherever you want for development, but keep in mind that you'll have to use the adb program in the tools/ folder to send files to the emulator, so you'll need access between your solution and the tools/ folder. 
Also, you should refrain from moving the location of the SDK directory, since this will break the build scripts (they will need to be manually updated to reflect the new SDK location before they will work again).
[bookmark: buildingwithant]Building an Android Application
Use the Ant build.xml file generated by activityCreator to build your application.
1. If you don't have it, you can obtain Ant from the Apache Ant home page. Install it and make sure it is on your executable path. 
2. Before calling Ant, you need to declare the JAVA_HOME environment variable to specify the path to where the JDK is installed. 
Note: When installing JDK on Windows, the default is to install in the "Program Files" directory. This location will cause ant to fail, because of the space. To fix the problem, you can specify the JAVA_HOME variable like this: set JAVA_HOME=c:\Prora~1\Java\. The easiest solution, however, is to install JDK in a non-space directory, for example: c:\java\jdk1.6.0_02. 
3. If you have not done so already, follow the instructions for Creating a New Project above to set up the project. 
4. You can now run the Ant build file by simply typing ant in the same folder as the build.xml file for your project. Each time you change a source file or resource, you should run ant again and it will package up the latest version of the application for you to deploy. 
Running an Android Application
To run a compiled application, you will upload the .apk file to the /data/app/ directory in the emulator using the adb tool as described here:
1. Start the emulator (run <your_sdk_dir>/tools/emulator from the command line) 
2. On the emulator, navigate to the home screen (it is best not to have that application running when you reinstall it on the emulator; press the Home key to navigate away from that application). 
3. Run adb install myproject/bin/<appname>.apk to upload the executable. So, for example, to install the Lunar Lander sample, navigate in the command line to <your_sdk_dir>/sample/LunarLander and type ../../tools/adb install bin/LunarLander.apk 
4. In the emulator, open the list of available applications, and scroll down to select and start your application. 
Note: When you install an Activity for the first time, you might have to restart the emulator before it shows up in the application launcher, or other applications can call it. This is because the package manager usually only examines manifests completely on emulator startup.
Attaching a Debugger to Your Application
This section describes how to display debug information on the screen (such as CPU usage), as well as how to hook up your IDE to debug running applications on the emulator. 
Attaching a debugger is automated using the Eclipse plugin, but you can configure other IDEs to listen on a debugging port to receive debugging information.
1. Start the Dalvik Debug Monitor Server (DDMS) tool , which acts as a port forwarding service between your IDE and the emulator. 
2. Set optional debugging configurations on your emulator, such as blocking application startup for an activity until a debugger is attached. Note that many of these debugging options can be used without DDMS, such as displaying CPU usage or screen refresh rate on the emulator. 
3. [bookmark: eclipse]Configure your IDE to attach to port 8700 for debugging. We include information on how to set up Eclipse to debug your project. 
Configuring your IDE to attach to the debugging port
DDMS will assign a specific debugging port to every virtual machine that it finds on the emulator. You must either attach your IDE to that port (listed on the Info tab for that VM), or you can use a default port 8700 to connect to whatever application is currently selected on the list of discovered virtual machines.
Your IDE should attach to your application running on the emulator, showing you its threads and allowing you to suspend them, inspect their state, and set breakpoints. If you selected "Wait for debugger" in the Development settings panel the application will run when Eclipse connects, so you will need to set any breakpoints you want before connecting.
Changing either the application being debugged or the "Wait for debugger" option causes the system to kill the selected application if it is currently running. You can use this to kill your application if it is in a bad state by simply going to the settings and toggling the checkbox.
[bookmark: debugging]Debugging
Android has a fairly extensive set of tools to help you debug your programs: 
· DDMS - A graphical program that supports port forwarding (so you can set up breakpoints in your code in your IDE), screen captures on the emulator, thread and stack information, and many other features. You can also run logcat to retrieve your Log messages. See the linked topic for more information. 
· logcat - Dumps a log of system messages. The messages include a stack trace when the emulator throws an error, as well as Log messages. To run logcat, see the linked topic. 
· ...
· I/MemoryDealer( 763): MemoryDealer (this=0x54bda0): Creating 2621440 bytes heap at 0x438db000
· I/Logger( 1858): getView() requesting item number 0
· I/Logger( 1858): getView() requesting item number 1
· I/Logger( 1858): getView() requesting item number 2
· D/ActivityManager( 763): Stopping: HistoryRecord{409dbb20 com.google.android.home.AllApps}
...
· Android Log- A logging class to print out messages to a log file on the emulator. You can read messages in real time if you run logcat on DDMS (covered next). Add a few logging method calls to your code.
To use the Log class, you just call Log.v() (verbose), Log.d() (debug), Log.i() (information), Log.w() (warning) or Log.e (error) depending on the importance you wish to assign the log message.
Log.i("MyActivity", "MyClass.getView() — Requesting item number " + position) 
You can use logcat to read these messages
· Traceview - Android can save a log of method calls and times to a logging file that you can view in a graphical reader called Traceview. See the linked topic for more information. 
· Eclipse plugin - The Eclipse Android plugin incorporates a number of these tools (ADB, DDMS, logcat output, and other functionality). See the linked topic for more information. 
· Debug and Test Device Settings - Android exposes several settings that expose useful information such as CPU usage and frame rate. See Debug and Test Settings on the Emulator below. 
Also, see the Troubleshooting section of the doc to figure out why your application isn't appearing on the emulator, or why it's not starting. 
[bookmark: additionaldebugging]Debug and Test Settings on the Device
Android lets you set a number of settings that will make it easier to test and debug your applications. To get to the development settings page on the emulator, go to Dev Tools > Development Settings. This will open the development settings page with the following options (among others):
· Debug app   Selects the application that will be debugged. You do not need to set this to attach a debugger, but setting this value has two effects: 
· It will prevent Android from throwing an error if you pause on a breakpoint for a long time while debugging. 
· It will enable you to select the Wait for Debugger option to pause application startup until your debugger attaches (described next). 
· Wait for debugger    Blocks the selected application from loading until a debugger attaches. This way you can set a breakpoint in onCreate(), which is important to debug the startup process of an Activity. When you change this option, any currently running instances of the selected application will be killed. In order to check this box, you must have selected a debug application as described in the previous option. You can do the same thing by adding waitForDebugger() to your code. 
· Immediately destroy activities   Tells the system to destroy an activity as soon as it is stopped (as if Android had to reclaim memory).  This is very useful for testing the onFreeze(Bundle) / onCreate(android.os.Bundle) code path, which would otherwise be difficult to force. Choosing this option will probably reveal a number of problems in your application due to not saving state. 
· Show screen updates    Flashes a momentary pink rectangle on any screen sections that are being redrawn. This is very useful for discovering unnecessary screen drawing. 
· Show CPU usage   Displays CPU meters at the top of the screen, showing how much the CPU is being used. The top red bar shows overall CPU usage, and the green bar underneath it shows the CPU time spent in compositing the screen. Note: You cannot turn this feature off once it is on, without restarting the emulator. 
· Show background   Displays a background pattern when no activity screens are visible. This typically does not happen, but can happen during debugging. 
These settings will be remembered across emulator restarts. 
[bookmark: toptips]Top Debugging Tips
[bookmark: stackdump]Quick stack dump 
To obtain a stack dump from emulator, you can log in with adb shell, use "ps" to find the process you want, and then "kill -3 ". The stack trace appears in the log file. 
[bookmark: displayinfo]Displaying useful info on the emulator screen 
The device can display useful information such as CPU usage or highlights around redrawn areas. Turn these features on and off in the developer settings window as described in Setting debug and test configurations on the emulator. 
[bookmark: dumpstate]Getting system state information from the emulator (dumpstate) 
You can access dumpstate information from the Dalvik Debug Monitor Service tool. See dumpsys and dumpstate on the adb topic page. 
[bookmark: dumpsys]Getting application state information from the emulator (dumpsys) 
You can access dumpsys information from the Dalvik Debug Monitor Service tool. See dumpsys and dumpstate on the adb topic page. 
[bookmark: radioinfo]Getting wireless connectivity information 
You can get information about wireless connectivity using the Dalvik Debug Monitor Service tool. From the Device menu, select "Dump radio state". 
[bookmark: loggingdata]Logging Trace Data 
You can log method calls and other tracing data in an activity by calling android.os.Debug.startMethodTracing(). See Running the Traceview Debugging Program for details. 
[bookmark: logradio]Logging Radio Data 
By default, radio information is not logged to the system (it is a lot of data). However, you can enable radio logging using the following commands: 
adb shell
logcat -b radio
[bookmark: adb]Running adb 
Android ships with a tool called adb that provides various capabilities, including moving and syncing files to the emulator, forwarding ports, and running a UNIX shell on the emulator. See Using adb for details. 
[bookmark: screencaps]Getting screen captures from the emulator 
[bookmark: debughelpers]Dalvik Debug Monitor Server (DDMS) can capture screenshots from the emulator. 
Using debugging helper classes 
Android provides debug helper classes such as util.Log and Debug for your convenience. 
[bookmark: building]Building and Installing an Android Application
Android requires custom build tools to be able to properly build the resource files and other parts of an Android application. Because of this, you must have a specialized build environment for your application. 
Custom Android compilation steps include compiling the XML and other resource files, and creating the proper output format. A compiled Android application is an .apk file, which is a compressed file containing .dex files, resource files, raw data files, and other files. You can create a properly structured Android project either from scratch, or from existing source files. 
Android does not currently support development of third party applications in native code (C/C++).
The recommended way to develop an Android application is to use Eclipse with the Android plugin, which provides support for building, running, and debugging Android applications. 
If you have another IDE, Android provides tools for other IDEs to build and debug Android applications, but they are not as integrated. 
[bookmark: uninstalling]Removing an Android Application
To remove an application that you have installed on the emulator, you will need to run adb and delete the .apk file you sent to the emulator when you installed it. Use adb shell to drop into a shell on the device as described in the linked topic, navigate to data/app/, and then remove the file using rm your_app.apk. 
[bookmark: tips]Eclipse Tips 
[bookmark: arbitraryexpressions]Executing arbitrary Java expressions in Eclipse
You can execute arbitrary code when paused at a breakpoint in Eclipse. For example, when in a function with a String argument called "zip", you can get information about packages and call class methods. You can also invoke arbitrary static methods: for example, entering android.os.Debug.startMethodTracing() will start dmTrace. 
Open a code execution window, select Window>Show View>Display from the main menu to open the Display window, a simple text editor. Type your expression, highlight the text, and click the 'J' icon (or CTRL + SHIFT + D) to run your code. The code runs in the context of the selected thread, which must be stopped at a breakpoint or single-step point. (If you suspend the thread manually, you have to single-step once; this doesn't work if the thread is in Object.wait().)
If you are currently paused on a breakpoint, you can simply highlight and execute a piece of source code by pressing CTRL + SHIFT + D. 
You can highlight a block of text within the same scope by pressing ALT +SHIFT + UP ARROW to select larger and larger enclosing blocks, or DOWN ARROW to select smaller blocks. 
Here are a few sample inputs and responses in Eclipse using the Display window.
	Input
	Response

	zip
	(java.lang.String) /work/device/out/linux-x86-debug/android/app/android_sdk.zip

	zip.endsWith(".zip")
	(boolean) true

	zip.endsWith(".jar")
	(boolean) false


You can also execute arbitrary code when not debugging by using a scrapbook page. Search the Eclipse documentation for "scrapbook".
Running DDMS Manually
Although the recommended way to debug is to use the ADT plugin, you can manually run DDMS and configure Eclipse to debug on port 8700. (Note: Be sure that you have first started DDMS). 


Anatomy of an Android Application

There are four building blocks to an Android application: 
· Activity 
· Intent Receiver 
· Service 
· Content Provider 
Not every application needs to have all four, but your application will be written with some combination of these. 
Once you have decided what components you need for your application, you should list them in a file called AndroidManifest.xml. This is an XML file where you declare the components of your application and what their capabilities and requirements are. See the Android manifest file documentation for complete details. 
Activity
Activities are the most common of the four Android building blocks. An activity is usually a single screen in your application. Each activity is implemented as a single class that extends the Activity base class. Your class will display a user interface composed of Views and respond to events. Most applications consist of multiple screens. For example, a text messaging application might have one screen that shows a list of contacts to send messages to, a second screen to write the message to the chosen contact, and other screens to review old messages or change settings. Each of these screens would be implemented as an activity. Moving to another screen is accomplished by a starting a new activity. In some cases an activity may return a value to the previous activity -- for example an activity that lets the user pick a photo would return the chosen photo to the caller. 
When a new screen opens, the previous screen is paused and put onto a history stack. The user can navigate backward through previously opened screens in the history. Screens can also choose to be removed from the history stack when it would be inappropriate for them to remain. Android retains history stacks for each application launched from the home screen. 
Intent and Intent Filters
Android uses a special class called an Intent to move from screen to screen. An intent describes what an application wants done. The two most important parts of the intent data structure are the action and the data to act upon. Typical values for action are MAIN (the front door of the application), VIEW, PICK, EDIT, etc. The data is expressed as a URI. For example, to view contact information for a person, you would create an intent with the VIEW action and the data set to a URI representing that person. 
There is a related class called an IntentFilter. While an intent is effectively a request to do something, an intent filter is a description of what intents an activity (or intent receiver, see below) is capable of handling. An activity that is able to display contact information for a person would publish an IntentFilter that said that it knows how to handle the action VIEW when applied to data representing a person. Activities publish their IntentFilters in the AndroidManifest.xml file. 
Navigating from screen to screen is accomplished by resolving intents. To navigate forward, an activity calls startActivity(myIntent). The system then looks at the intent filters for all installed applications and picks the activity whose intent filters best matches myIntent. The new activity is informed of the intent, which causes it to be launched. The process of resolving intents happens at run time when startActivity is called, which offers two key benefits: 
· Activities can reuse functionality from other components simply by making a request in the form of an Intent 
· Activities can be replaced at any time by a new Activity with an equivalent IntentFilter 
Intent Receiver
You can use an IntentReceiver when you want code in your application to execute in reaction to an external event, for example, when the phone rings, or when the data network is available, or when it's midnight. Intent receivers do not display a UI, although they may use the NotificationManager to alert the user if something interesting has happened. Intent receivers are registered in AndroidManifest.xml, but you can also register them from code using Context.registerReceiver(). Your application does not have to be running for its intent receivers to be called; the system will start your application, if necessary, when an intent receiver is triggered. Applications can also send their own intent broadcasts to others with Context.broadcastIntent(). 
Service
A Service is code that is long-lived and runs without a UI. A good example of this is a media player playing songs from a play list. In a media player application, there would probably be one or more activities that allow the user to choose songs and start playing them. However, the music playback itself should not be handled by an activity because the user will expect the music to keep playing even after navigating to a new screen. In this case, the media player activity could start a service using Context.startService() to run in the background to keep the music going. The system will then keep the music playback service running until it has finished. (You can learn more about the priority given to services in the system by reading Life Cycle of an Android Application.) Note that you can connect to a service (and start it if it's not already running) with the Context.bindService() method. When connected to a service, you can communicate with it through an interface exposed by the service. For the music service, this might allow you to pause, rewind, etc. 
Content Provider
Applications can store their data in files, an SQLite database, or any other mechanism that makes sense. A content provider, however, is useful if you want your application's data to be shared with other applications. A content provider is a class that implements a standard set of methods to let other applications store and retrieve the type of data that is handled by that content provider. 
To get more details on content providers, see Accessing Content Providers. 




Life Cycle of an Android Application

In most cases, every Android application runs in its own Linux process. This process is created for the application when some of its code needs to be run, and will remain running until it is no longer needed and the system needs to reclaim its memory for use by other applications.
An unusual and fundamental feature of Android is that an application process's lifetime is not directly controlled by the application itself. Instead, it is determined by the system through a combination of the parts of the application that the system knows are running, how important these things are to the user, and how much overall memory is available in the system.
It is important that application developers understand how different application components (in particular Activity, Service, and IntentReceiver) impact the lifetime of the application's process. Not using these components correctly can result in the system killing the application's process while it is doing important work.
A common example of a process life-cycle bug is an IntentReceiver that starts a thread when it receives an Intent in its onReceiveIntent() method, and then returns from the function. Once it returns, the system considers that IntentReceiver to be no longer active, and thus its hosting process no longer needed (unless other application components are active in it). Thus, it may kill the process at any time to reclaim memory, terminating the spawned thread that is running in it. The solution to this problem is to start a Service from the IntentReceiver, so the system knows that there is still active work being done in the process.
To determine which processes should be killed when low on memory, Android places them into an "importance hierarchy" based on the components running in them and the state of those components. These are, in order of importance:
1. A foreground process is one that is required for what the user is currently doing. Various application components can cause its containing process to be considered foreground in different ways. A process is considered to be in the foreground if any of the following conditions hold: 
· It is running an Activity at the top of the screen that the user is interacting with (its onResume() method has been called). 
· It has an IntentReceiver that is currently running (its IntentReceiver.nReceiveIntent() method is executing). 
· It has a Service that is currently executing code in one of its callbacks (Service.onCreate(), Service.onStart(), or Service.onDestroy()). 
There will only ever be a few such processes in the system, and these will only be killed as a last resort if memory is so low that not even these processes can continue to run. Generally at this point the device has reached a memory paging state, so this action is required in order to keep the user interface responsive. 
2. A visible process is one holding an Activity that is visible to the user on-screen but not in the foreground (its onPause() method has been called). This may occur, for example, if the foreground activity has been displayed with a dialog appearance that allows the previous activity to be seen behind it. Such a process is considered extremely important and will not be killed unless doing so is required to keep all foreground processes running. 
3. A service process is one holding a Service that has been started with the startService() method. Though these processes are not directly visible to the user, they are generally doing things that the user cares about (such as background mp3 playback or background network data upload or download), so the system will always keep such processes running unless there is not enough memory to retain all foreground and visible process. 
4. A background process is one holding an Activity that is not currently visible to the user (its onStop() method has been called). These processes have no direct impact on the user experience. Provided they implement their activity life cycle correctly (see Activity for more details), the system can kill such processes at any time to reclaim memory for one of the three previous processes types. Usually there are many of these processes running, so they are kept in an LRU list to ensure the process that was most recently seen by the user is the last to be killed when running low on memory. 
5. An empty process is one that doesn't hold any active application components. The only reason to keep such a process around is as a cache to improve startup time the next time a component of its application needs to run. As such, the system will often kill these processes in order to balance overall system resources between these empty cached processes and the underlying kernel caches. 
When deciding how to classify a process, the system picks the most important level of all the components currently active in the process. See the Activity, Service, and IntentReceiver documentation for more detail on how each of these components contribute to the overall life cycle of a process. The documentation for each of these classes describes in more detail how they impact the overall life cycle of their application.
A process's priority may also be increased based on other dependencies a process has to it. For example, if process A has bound to a Service with the Context.BIND_AUTO_CREATE flag or is using a ContentProvider in process B, then process B's classification will always be at least as important as process A's.


Package Index
These are the Android APIs.
	android 
	Contains the resource classes used by standard Android applications. 

	android.app 
	High-level classes encapsulating the overall Android application model. 

	android.awt 
	Provides non-widget parts of the Abstract Windowing Tolkit (AWT). 

	android.content 
	Contains classes for accessing and publishing data on the device. 

	android.content.pm 
	 

	android.database 
	Contains classes to explore data returned through a content provider. 

	android.database.sqlite 
	Contains the SQLite database management classes that an application would use to manage its own private database. 

	android.drm 
	 

	android.graphics 
	Provides low level graphics tools such as canvases, color filters, points, and rectangles that let you handle drawing to the screen directly. 

	android.graphics.drawable 
	Provides classes to manage a variety of visual elements that are intended for display only, such as bitmaps and gradients. 

	android.graphics.drawable.shapes 
	 

	android.graphics.glutils 
	 

	android.hardware 
	Provides support for hardware devices that may not be present on every Android device. 

	android.location 
	Classes defining Android location-based and related services. 

	android.media 
	 

	android.net 
	Classes that help with network access, beyond the normal java.net.* APIs. 

	android.opengl 
	Provides OpenGL utilities. 

	android.os 
	Provides basic operating system services, message passing, and inter-process communication on the device. 

	android.provider 
	Provides convenience classes to access the content providers supplied by Android. 

	android.sax 
	A framework that makes it easy to write efficient and robust SAX handlers. 

	android.telephony 
	Provides tools to make, receive, and monitor phone calls and phone status. 

	android.telephony.gsm 
	Provides classes to control or read data from GSM phones. 

	android.telephony.gsm.stk 
	Provides classes for SIM Toolkit Service. 

	android.test.mock 
	 

	android.text 
	Provides classes used to render or track text and text spans on the screen. 

	android.text.method 
	Provides classes that monitor or modify keypad input. 

	android.text.style 
	Provides classes used to view or change the style of a span of text in a View object. 

	android.text.util 
	 

	android.util 
	Provides common utility methods such as date/time manipulation, base64 encoders and decoders, string and number conversion methods, and XML utilities. 

	android.view 
	Provides classes that expose basic user interface classes that handle screen layout and interaction with the user. 

	android.view.animation 
	Provides classes that handle tweened animations. 

	android.webkit 
	Provides tools for browsing the web. 

	android.widget 
	The widget package contains (mostly visual) UI elements to use on your Application screen. 

	com.google.android.gtalkservice 
	 

	com.google.android.maps 
	 

	java.io 
	Provides input and output facilities by means of streaming, filesystem access and serialization. 

	java.lang 
	Provides core classes of the Android environment. 

	java.lang.annotation 
	Provides a couple of pre-defined annotation classes as well as exceptions that can occur when dealing with annotations. 

	java.lang.instrument 
	Provides classes and interfaces needed for instrumenting applications. 

	java.lang.ref 
	 

	java.lang.reflect 
	 

	java.math 
	This package provides arbitrary-precision integers and decimals. 

	java.net 
	Provides networking-related functionality, such as streaming and datagram sockets, handling of Internet addresses, and dealing with HTTP requests. 

	java.nio 
	Provides buffers that help handling data. 

	java.nio.channels 
	Channels provide a way to connect to sources of data such as files, sockets or other structures that allow input and/or output of data. 

	java.nio.channels.spi 
	Service-provider classes for nio channels. 

	java.nio.charset 
	This package allows translating between bytes and different character sets. 

	java.nio.charset.spi 
	Service-provider classe for nio charset. 

	java.security 
	 

	java.security.acl 
	 

	java.security.cert 
	 

	java.security.interfaces 
	 

	java.security.spec 
	 

	java.sql 
	Provides a standard interface for accessing SQL-based databases. 

	java.text 
	The java.text package allows to uncouple the text in the application from a natural language. 

	java.util 
	Provides an extensive set of utility classes. 

	java.util.concurrent 
	Utility classes commonly useful in concurrent programming. 

	java.util.concurrent.atomic 
	A small toolkit of classes that support lock-free thread-safe programming on single variables. 

	java.util.concurrent.locks 
	Interfaces and classes providing a framework for locking and waiting for conditions that is distinct from built-in synchronization and monitors. 

	java.util.jar 
	The java.jar package gives access to jar files content. 

	java.util.logging 
	This package allows to add logging to any application. 

	java.util.prefs 
	Provides a preferences mechanism, that is, a means of writing configuration data (key/value pairs) to a persistent data store and retrieving it from there. 

	java.util.regex 
	Provides an implementation of regular expressions, which is useful for matching, searching, and replacing strings based on patterns. 

	java.util.zip 
	This package can read and write the standard zip format. 

	javax.crypto 
	 

	javax.crypto.interfaces 
	 

	javax.crypto.spec 
	 

	javax.microedition.khronos.opengles 
	 

	javax.net 
	 

	javax.net.ssl 
	 

	javax.security.auth 
	 

	javax.security.auth.callback 
	 

	javax.security.auth.login 
	 

	javax.security.auth.x500 
	 

	javax.security.cert 
	 

	javax.sound.midi 
	 

	javax.sound.midi.spi 
	 

	javax.sound.sampled 
	 

	javax.sound.sampled.spi 
	 

	javax.sql 
	Provides extensions to the standard interface for accessing SQL-based databases. 

	javax.xml.parsers 
	Provides facilities for parsing XML documents and building Document Object Model (DOM) trees from them. 

	junit.extensions 
	 

	junit.framework 
	 

	org.apache.http 
	The core interfaces and classes of the HTTP components. 

	org.apache.http.auth 
	The API for client-side HTTP authentication against a server, commonly referred to as HttpAuth. 

	org.apache.http.auth.params 
	Parameters for configuring HttpAuth. 

	org.apache.http.client 
	The API for client-side HTTP communication and entry point to the HttpClient module. 

	org.apache.http.client.methods 
	Request implementations for the various HTTP methods like GET and POST. 

	org.apache.http.client.methods.multipart 
	Provides Multipart support classes for the MultipartPostMethod. 

	org.apache.http.client.params 
	Parameters for configuring HttpClient. 

	org.apache.http.client.protocol 
	Additional request and response interceptors. 

	org.apache.http.client.utils 
	Helpers and utility classes for HttpClient. 

	org.apache.http.conn 
	The client-side connection management and handling API at the heart of what is referred to as HttpConn. 

	org.apache.http.conn.params 
	Parameters for configuring HttpConn. 

	org.apache.http.conn.ssl 
	TLS/SSL specific parts of the HttpConn API. 

	org.apache.http.conn.util 
	 

	org.apache.http.cookie 
	The API for client-side state management via cookies, commonly referred to as HttpCookie. 

	org.apache.http.cookie.params 
	Parameters for configuring HttpCookie. 

	org.apache.http.entity 
	Representations for HTTP message entities. 

	org.apache.http.impl 
	Default implementations for interfaces in org.apache.http. 

	org.apache.http.impl.auth 
	 

	org.apache.http.impl.client 
	 

	org.apache.http.impl.conn 
	 

	org.apache.http.impl.conn.tsccm 
	The implementation of a thread-safe client connection manager. 

	org.apache.http.impl.cookie 
	 

	org.apache.http.impl.entity 
	Default implementations for interfaces in org.apache.http.entity. 

	org.apache.http.impl.io 
	Default implementations for interfaces in org.apache.http.io. 

	org.apache.http.io 
	The transport layer abstraction of the HTTP components. 

	org.apache.http.message 
	A selection of HTTP message implementations. 

	org.apache.http.params 
	The parameterization framework for HTTP components. 

	org.apache.http.protocol 
	HTTP protocol execution framework. 

	org.apache.http.util 
	Mostly utility classes with static helper methods for various purposes. 

	org.apache.http.util.concurrent 
	Interfaces corresponding to java.util.concurrent. 

	org.bluez 
	Provides classes to manage Bluetooth functionality on the device. 

	org.json 
	 

	org.w3c.dom 
	Provides the official W3C Java bindings for the Document Object Model, level 2 core. 

	org.xml.sax 
	This package provides the core SAX APIs. 

	org.xml.sax.ext 
	This package contains interfaces to SAX2 facilities that conformant SAX drivers won't necessarily support. 

	org.xml.sax.helpers 
	This package contains "helper" classes, including support for bootstrapping SAX-based applications. 
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